u-Grabber und neutrinoHD?

Windows Streaming-Tool

Moderator: saggi

Nachricht
Autor
Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#76 Beitrag von Pedant » Fr 01 Apr 2011, 21:08

Hallo saggi,
1-mal heruntergeladen
wer war da vor mir?
zuerst die gute Nachricht
Und wo ist die Schlechte?
Einige Modi habe ich schon an die Coolstream angepasst
Sag Bescheid wenn ich was testen oder ausprobieren soll.
Also HD auf die Festplatte ist Hölle, da rutschen die Gigabytes nur so weg...
Ja, schlimm. 1,5 MB /sek bei 720. 1080 hab ich noch nicht ausprobiert.
vor allem mal die Aufnahme implementiert
Das klingt super
und vielleicht bekommen wir auch noch irgendwann udrec ins HD-Image.
Noch bin ich im Büro, werde aber später oder spätestens morgen einen Testlauf machen.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
saggi
u-Grabber Dev
u-Grabber Dev
Beiträge: 1173
Registriert: So 21 Mär 2004, 15:11
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#77 Beitrag von saggi » Fr 01 Apr 2011, 21:19

Hallo Frank,
Pedant hat geschrieben:Und wo ist die Schlechte?
Habe ich vergessen: Port funktioniert ausschließlich 31339.
Pedant hat geschrieben:Sag Bescheid wenn ich was testen oder ausprobieren soll.
Das lohnt glaube ich noch nicht ;), aber wenn Dir was auffällt einfach sagen.
Pedant hat geschrieben:Noch bin ich im Büro,

Ohje!
werde aber später oder spätestens morgen einen Testlauf machen.
Dabei aber viel Erfolg. Ich bin gespannt. Ich habe immer nur kurze Testläufe gemacht.

saggi

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#78 Beitrag von Pedant » Sa 02 Apr 2011, 15:42

Hallo saggi,

ich habe vorhin eine erfolgreiche Test-Aufnahme in SD mit einem PC-Timer gemacht.
Es waren planmäßig knapp 50 Min. die vorsätzlich über einen Sendungswechsel hinweg gingen. Es war allerdings durchgehend 16:9 und auch die Audio-Pids waren senderseitig nicht unterbrochen, doch war zwischen den Sendungen der AC3-Ton in 2.0 statt in 5.1.
Es wurde eine TS-Datei geschrieben mit AC3 und 2-mal Stereo, die von ProjektX ohne nennenswerte Meldungen demuxxt werden konnte.

Ich werde jetzt noch eine HD-Aufnahme machen.
Aber was mach ich eigentlich anschließend damit?
Ich werde dafür mal einen neuen Thread eröffnen.
Optionen -> u-Grabber -> Allgemein -> [2.000] ms Timeout für Anfragen an die DBox
Wenn ich den Wert auf 5000 ms erhöhe, dann funktioniert es. 4000 ms sind noch zuwenig. Das absolute Minimum aufs Tausendstel genau, habe ich jetzt nicht ermittelt, da es ohnehin ein individueller Wert ist.
Geändert hat es sich, denn jetzt ist sind 2300 ms ausreichend, bei 2200 ms oder weniger klappt es noch nicht.
2.300 ms hat geschrieben:02.04.2011 16:21:11: WebZugriff: WebZugriff gestartet
02.04.2011 16:21:16: zapto: 39d400020085000a
02.04.2011 16:21:16: GetMode: tv
02.04.2011 16:21:16: Debug: NeutrinoHD erkannt
02.04.2011 16:21:16: BouquetList: Bouquetliste geladen
02.04.2011 16:21:16: GetTreeFromBouquet: 12 Bouquet gesamt, 5 Verdopplungen übersprungen
02.04.2011 16:21:17: ChannelList: Kanalliste geladen
2.200 ms hat geschrieben:02.04.2011 16:22:30: WebZugriff: WebZugriff gestartet
02.04.2011 16:22:35: Fehler bei Zugriff auf: coolstream, Meldung: Timeout für Vorgang überschritten
bei System.Net.HttpWebRequest.GetResponse()
bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy)
02.04.2011 16:22:35: URL: http://coolstream/
02.04.2011 16:22:35: GetMode: tv
02.04.2011 16:22:35: Debug: NeutrinoHD erkannt
02.04.2011 16:22:35: BouquetList: Bouquetliste geladen
02.04.2011 16:22:35: GetTreeFromBouquet: 12 Bouquet gesamt, 5 Verdopplungen übersprungen
02.04.2011 16:22:35: ChannelList: Kanalliste geladen
Das, wie schon gesagt, ist kein Kummer für mich.
Ich wollt's Dir nur mitteilen.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#79 Beitrag von Pedant » Sa 02 Apr 2011, 18:57

Hallo saggi,

gerade viel mir wieder auf, dass bei der Timerliste unter "Aktiv" auch so eine nicht benutzbare Checkbox ist, wie vormals die bei "REC" bei den IP-Adressen.
Da könntest Du auch prima Deine neuen Flaggen einsetzen.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
saggi
u-Grabber Dev
u-Grabber Dev
Beiträge: 1173
Registriert: So 21 Mär 2004, 15:11
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#80 Beitrag von saggi » So 03 Apr 2011, 12:49

Hallo Frank,
Pedant hat geschrieben:Da könntest Du auch prima Deine neuen Flaggen einsetzen.
Erledigt.

Außerdem gibt es jetzt unter Optionen -> Allgemein einen Haken, das u-Grabber auch weget einsetzen soll, wenn HD erkannt wurde(default ist True).

saggi

Edit: Anhang entfernt

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#81 Beitrag von Pedant » So 03 Apr 2011, 18:36

Hallo saggi,

die Flaggen sind da und funktionieren (rot/grün).

Der WGet-Haken ist da und funktioniert auch.
DBox mit und ohne Haken -> udrec
Coolstream ohne Haken -> udrec mit Fehler
Coolstream mit Haken -> wget
Ich werde jetzt noch eine HD-Aufnahme machen.
Diese Timer-wget-HD-Aufnahme habe ich gestern gemacht.
Gut 90 Min. lang landeten dann knapp 9 GB auf dem PC ("Arte HD" also 720p).

Im MPC hakt die Wiedergabe deutlich und es wird auch nur die erste Tonspur angeboten.
Im VLC lässt sie sich prima abspielen inklusive der drei Ton-Versionen.
Für diese Dateien ist VLC offensichtlich die bessere Wahl.
Ich konnte sie auch mit TS Packet Editor erfolgreich schneiden.

Was nicht ohne Weiteres funktioniert ist die Wiedergabe an der Coolstream.
Abspielen (Multiformat)
Die Wiedergabe über Netzwerk oder auch nach Kopieren auf die interne Platte, bricht direkt nach dem Start wieder ab, zeigt aber zumindest kurz oder ganz kurz ein korrektes Bild.
TS Filmarchiv (eigene Aufnahmen)
Um das auszuprobieren habe ich die Aufnahme in das Aufnahme-Verzeichnis der lokalen Festplatte der Coolstream kopiert.
Da startet die Wiedergabe aber gar nicht.
Was ich dann ausprobiert habe ist, die XLM, die u-Grabber erzeugt hat zu modifizieren, sodass sie formal zu denen passt, die die Coolstream bei einer Aufnahme erzeugt.
Diese XML mit in das Aufnahme-Verzeichnis der lokalen Festplatte der Coolstream kopiert, führte dazu, dass die Aufnahme einwandfrei abspielbar war.
(Das hat so auch mit meiner geschnittenen Fassung funktioniert.)
Als Vorlage für die Modifikation habe ich eine kurze Aufnahme vom selben Sender mit der Coolstream gemacht und die daraus entstandene als Vorlage verwendet.
Hier die XML von u-Grabber und die modifizierte, coolstreammäßige zum Vergleich:

u-Grabber

Code: Alles auswählen

<?xml version="1.0" encoding="utf-8"?>

<neutrino commandversion="1">
  <record command="record">
    <epgtitle>Ägypten: Geburt einer Großmacht</epgtitle>
    <info1>Deutschland, Ägypten, Israel 2010</info1>
    <info2>Um 3.000 vor Christus entsteht mit der Vereinigung (Zeile von mir gekürzt)</info2>
    <mode>1</mode>
    <channelname>ARTE HD</channelname>
    <videopid>00573</videopid>
    <audiopids selected="00574 00575 00576">
      <audio pid="00574" name="stereo" />
      <audio pid="00575" name="französisch" />
      <audio pid="00576" name="Dolby Digital 2.0" />
    </audiopids>
    <length>93</length>
    <genremajor>0</genremajor>
    <genreminor>0</genreminor>
    <serienname> </serienname>
    <productioncountry> </productioncountry>
    <productiondate>0</productiondate>
  </record>
</neutrino>
modifizierte XML

Code: Alles auswählen

<?xml version="1.0" encoding="UTF-8"?>

<neutrino commandversion="1">
	<record command="record">
		<channelname>ARTE HD</channelname>
		<epgtitle>Ägypten: Geburt einer Großmacht</epgtitle>
		<id>5878324100000000000</id>
		<info1>Deutschland, Ägypten, Israel 2010</info1>
		<info2>Um 3.000 vor Christus entsteht mit der Vereinigung (Zeile von mir gekürzt)</info2>
		<epgid>48175167517068551</epgid>
		<mode>1</mode>
		<videopid>573</videopid>
		<videotype>1</videotype>
		<audiopids>
			<audio pid="574" audiotype="0" selected="1" name="stereo"/>
			<audio pid="575" audiotype="0" selected="0" name="französisch"/>
			<audio pid="576" audiotype="1" selected="0" name="Dolby Digital 2.0 (AC3)"/>
		</audiopids>
		<vtxtpid>578</vtxtpid>
		<genremajor>0</genremajor>
		<genreminor>0</genreminor>
		<serienname></seriename>
		<length>93</length>
		<productioncountry></productioncountry>
		<productiondate>0</productiondate>
		<qualitiy>0</qualitiy>
		<parentallockage>0</parentallockage>
		<dateoflastplay>1301844887</dateoflastplay>
		<bookmark>
			<bookmarkstart>0</bookmarkstart>
			<bookmarkend>0</bookmarkend>
			<bookmarklast>0</bookmarklast>
			<bookmarkuser bookmarkuserpos="0" bookmarkusertype="0" bookmarkusername=""/>
		</bookmark>
	</record>
</neutrino>
Die Aufnahme als solche werte ich als Erfolg.

Da sie leider nicht einfach per Abspielen (Multiformat) an der Coolstream wiedergegeben werden kann, muss man sich also recht bewusst entscheiden wo man den Timer setzt.
Ein u-Grabber-Timer für direkte Wiedergabe oder Weiterverarbeitung am PC oder
ein Box-Timer für direkte Wiedergabe an der Box.

Da das jetzt der erste "richtige" HD-Test war, weiß ich noch nicht ob obiges der Weisheit letzter Schluss ist, denn dass die TS-Datei nicht per Abspielen (Multiformat) abspielbar ist, ist schon eher merkwürdig.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
saggi
u-Grabber Dev
u-Grabber Dev
Beiträge: 1173
Registriert: So 21 Mär 2004, 15:11
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#82 Beitrag von saggi » Di 05 Apr 2011, 19:10

Hallo Frank,

das Abspielen der HD-Aufnahmen an der Coolstream ist bei mir ähnlich. SD funktioniert. Allerdings wird bei mir die xml richtig erkannt und ausgewertet.
Ich habe u-Grabber so umgebaut, das man PAT/PMT abwählen kann, am Abspielverhalten auf der CS hat das nichts geändert. Ich nehme mal mit der CS einen HD Sender auf und versuche den Stream zu analysieren. Profi bin ich da nicht, aber vielleicht gibt es ja Auffälligkeiten. Das wird aber wieder erst am Wochenende etwas werden.

Kannst Du das mit den xml noch einmal prüfen? Hier wurden alle erkannt.
Pedant hat geschrieben:Ein u-Grabber-Timer für direkte Wiedergabe oder Weiterverarbeitung am PC oder
ein Box-Timer für direkte Wiedergabe an der Box.
Immerhin kann man mit u-Grabber jetzt bequem auf der Coolstream Timer setzen, aus dem Movieguide oder dem EPG. Und ich bin zwar noch am probieren, aber bisher haben alle Aufnahmen der Coolstream an die angeschlossene Platte oder auch auf die Samba-Freigabe funktioniert.

saggi

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#83 Beitrag von Pedant » Di 05 Apr 2011, 20:33

Hallo saggi,
das Abspielen der HD-Aufnahmen an der Coolstream ist bei mir ähnlich. SD funktioniert.
Bei jeweils (SD/HS) welcher Art der Wiedergabe (Abspielen (Multiformat) / TS Filmarchiv (eigene Aufnahmen))?
Kannst Du das mit den xml noch einmal prüfen? Hier wurden alle erkannt.
Also auch die von u-Grabber erzeugten und dann der Box untergeschobenen werden bei Dir im TS Filmarchiv der Box erkannt?
Ich prüf's auf jeden Fall nochmal.
Immerhin kann man mit u-Grabber jetzt bequem auf der Coolstream Timer setzen, aus dem Movieguide oder dem EPG.
Nicht nur immerhin, das ist der erfreulichste Nutzen Deiner Arbeit und dass PC-Aufnahmen auch funktionieren ist auch klasse.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#84 Beitrag von Pedant » Fr 08 Apr 2011, 9:12

Hallo saggi,

gestern habe ich noch einen Test mit Arte HD gemacht, also eine Aufnahme auf dem PC erzeugt und diese dann (ts und xml) auf die Box kopiert.
Eine Wiedergabe per TS Filmarchiv (eigene Aufnahmen) war wieder erst möglich nachdem ich die xml per Hand modifiziert habe.
Ich werde das die Tage noch weiter untersuchen, aber im Moment erscheint es mir so, dass die Coolstream auf ihr eigenes xml-Format besteht.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
saggi
u-Grabber Dev
u-Grabber Dev
Beiträge: 1173
Registriert: So 21 Mär 2004, 15:11
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#85 Beitrag von saggi » Fr 08 Apr 2011, 17:59

Hallo Frank,

wie versprochen am Wochenende mal eingehender damit beschäftigt. Wie gesagt hat SD hier funktioniert, HD nicht. War etwas missverständlich ausgedrückt.

Ich habe mir die xml genauer angesehen und einmal zum Test mit u-Grabber und mit der Coolstream aufgenommen. Beides auf Das Erste HD. Nach Austausch xml von u-Grabber mit der von der CS wurde die Aufnahme korrekt abgespielt. Neutrino, oder besser der Movieplayer muss wohl wissen, in welchem Format die Datei vorliegt.

Wichtig scheint dabei der "videotype" zu sein: HD = 1, SD = 0.
Ich habe das Schreiben der xml so modifiziert, das wenn wget benutzt wird die Informationen entsprechend abgelegt werden. Die Informationen holt sich u-Grabber aus den Streaminformationen:
Enthält die Audiopid "dolby" im Namen, dann "audiotype" = 1, sonst 0
selected="1" ist immer die erste Audiopid
Ist die Auflösung X größer 720 dann ist "videotype" = 1, sonst 0

Mit diesen Modifikationen wurden eine SD und eine HD Aufnahme richtig von der CS erkannt und abgespielt. Ob das mit längeren als mit meinen Test-Aufnahmen funktioniert habe ich nicht getestet.

Jetzt hoffe ich auf Deine ausführlichen Tests ;-)

saggi

Edit: Anhang entfernt

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#86 Beitrag von Pedant » Mo 25 Apr 2011, 20:53

Hallo saggi,

aus Dir mitgeteilten, privaten Gründen blieben ausführliche Tests eine zeitlang aus.
Zu ausführlichen Tests kam ich jetzt auch noch nicht, aber zumindest kann ich bestätigen, dass HD-PC-Timer-Aufnahmen mit der aktuellen Version auch ohne Modifizierung der XML-Dateien per TS Filmarchiv (eigene Aufnahmen) korrekt abgespielt werden.
7-mal heruntergeladen
da scheint es mittlerweile ja auch weitere Teilnehmer zu geben, die Nachfrage oder Neugier langsam in Schwung zu kommen.

Frohe Ostern
Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
saggi
u-Grabber Dev
u-Grabber Dev
Beiträge: 1173
Registriert: So 21 Mär 2004, 15:11
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#87 Beitrag von saggi » Di 26 Apr 2011, 18:12

Hallo Frank,

danke Dir, das Du trotzdem kurz Zeit gefunden hast. Da die Funktion nun geklärt ist veröffentliche ich hier vorab Version 0.2.6.0, welche alle Änderungen, die wir hier gemeinsam erarbeitet haben, enthält.

Ich habe hierzu die übliche Datei vorbereitet:

Code: Alles auswählen

*Änderungen in V 0.2.6.0*
-	Unterstützung für Neutrino HD
	(getestet auf Coolstream NEO Cable, !WebServer ohne Authentifikation!)
- 	Bouquetliste: 
	unerwünschte Bouquets lassen sich ausblenden (Rechtsklick auf Bouquetname)
	Knoten "Alles Sender" enthält jeden Sender nur einmal, alphabetisch sortiert
-	Streamfunktion für Coolstream via wget
	Folgende Dateien sind dafür im u-Grabber Verzeichnis nötig:
		libeay32.dll
		libiconv2.dll
		libintl3.dll
		libssl32.dll
		wget.exe
-	Timer setzen überarbeitet, funktioniert nun auch für Neutrino HD
-	Channel2EPG.xml wird Boxabhängig gespeichert und abgerufen
-	Telnet: Farbinformationen werden gefiltert und nicht angezeigt, Login ohne Passwort möglich
-	Viele Optionen aus dem Hauptmenu erreichbar, nun mit Bildchen ;-)
-	Aufnahmestatus nun mit Icon statt mit Haken (Boxliste, Timerliste)

[Fixliste]
-	Timeoutprobleme bei Erstverbindung zur Box behoben
-	Diverse, was sonst noch aufgefallen ist...


*Änderungen in V 0.2.5.10*
-	Abschnitt [Extra] in der ini-Datei
	[Extra]
	Programm=D:\temp\NSendKeyF5.exe default: leer
	Minuten=5 default: 5
	MGEpisode=True default: False
	MaxFileNameLength=240 default: 240
	
	Programm: wird während der Aufnahme aufgerufen 
	Minuten: das Intervall zu den Aufrufen, ohne Angabe werden 5 min verwendet
	MGEpisode: wenn True dann wird der Episodentitel bei Programmierung aus dem Movieguide übernommen (Titel-Episode)
	MaxFileNameLength: Dateiname wird auf diese Länge beschränkt(Standarddateiname wird verwendet)

-	UserTimer: Programm vor dem Start einer Aufnahme als Server ausführen
	[X] Vor der Aufnahme starten UND spätestens [-1] Sek. vor Aufnahme
	

[Fixliste]
-	Usertimer: Menuleiste konnte Absturz verursachen, wenn ein Ziel nicht vorhanden ist
Außerdem hänge ich nochmals ein Komplettpaket inkl. wget an. Es ist immer noch eine Debug-Version mit Versionsnummer 0.2.5.25, allerdings sollte dieser Funktionsumfang dann der veröffentlichen Version entsprechen.
Es sollten alle Aufrufe an die Coolstream angepasst sein. Telnet: Webserver und sectionsd neu starten ist für die CS deaktiviert.
Pedant hat geschrieben:da scheint es mittlerweile ja auch weitere Teilnehmer zu geben, die Nachfrage oder Neugier langsam in Schwung zu kommen.
Naja, ohne Feedback lässt sich das schwerlich beurteilen, vielleicht nur Jäger und Sammler? :mrgreen:

Jetzt räume ich den Thread erst mal leer, die ganzen Anhänge weg...

saggi

Anhang entfernt

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#88 Beitrag von Pedant » Fr 29 Apr 2011, 9:49

Hallo saggi,
... veröffentliche ich hier vorab Version 0.2.6.0
Wo - oder kommt das erst noch?
Außerdem hänge ich nochmals ein Komplettpaket inkl. wget an. Es ist immer noch eine Debug-Version mit Versionsnummer 0.2.5.25, allerdings sollte dieser Funktionsumfang dann der veröffentlichen Version entsprechen.
Ich bin mir recht sicher, dass ich dieses Wochenende dazu kommen werde die neu Version durchzutesten.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Benutzeravatar
saggi
u-Grabber Dev
u-Grabber Dev
Beiträge: 1173
Registriert: So 21 Mär 2004, 15:11
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#89 Beitrag von saggi » Sa 30 Apr 2011, 18:19

Pedant hat geschrieben:Hallo saggi,
Zitat:
... veröffentliche ich hier vorab Version 0.2.6.0

Wo - oder kommt das erst noch?
Ok. erwischt. Falsch ausgedrückt. Eigentlich gemeint ist, das ich die Version 0.2.5.25 anhänge, welche den späteren Funktionsumfang der 0.2.6.0 entsprechen soll. Ich werde die Version so als "Release" der 0.2.6.0 übernehmen, wenn keine Auffälligkeiten mehr vorhanden sind.
Ohje, manchmal fällt es mir wirklich schwer das konfuse Gedankenspiel in meinem Kopf in Worte zu fassen :oops: :roll: :wink:
Pedant hat geschrieben:Ich bin mir recht sicher, dass ich dieses Wochenende dazu kommen werde die neu Version durchzutesten.
Das ist natürlich kein Problem!

saggi

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)

Benutzeravatar
Pedant
admin-c
admin-c
Beiträge: 4265
Registriert: Mo 04 Aug 2003, 16:22
Wohnort: Bad Vilbel
Kontaktdaten:

Re: u-Grabber und neutrinoHD?

#90 Beitrag von Pedant » So 01 Mai 2011, 19:15

Hallo saggi,

bei Netconsole und Telnet kommt keine Verbindung zustande.

Für einige der Verdbindungswerkzeuge sind Verbindungsdaten hinterlegt.
Es wäre schön, wenn die vorbelegten Felder beim Wechsel der aktuellen Box auch der Box entsprechend aktualisiert würden.
Ähnliches gilt fürs Webinterface. Da wird durch den Wechsel der aktuellen Box das Webinterface nicht gewechselt.

Der Wechsel in den Radio-Modus verändert zwar die Bouquets-Liste, es werden aber immer noch nur Fernsehsender angezeigt und keine Radiosender.
Mit einer dbox2 funktioniert das, mit der Coolstream nicht.

"Box" statt "DBox"
Bei "ms Timerout für Anfragen an die DBox" steht noch DBox statt einfach nur Box.

Ob das alles noch für die 0.2.6.0 geändert werden soll oder Du Dir was für die 0.2.6.1 aufhebst ist Deine Entscheidung.
Ich würde ein baldiges Release begrüßen und endgültig fertig oder gänzlich fehlerfrei wird das Programm, so gut es auch tätsächlich ist, vermutlich nie sein.

Gruß Frank
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R

Antworten