Jack the Grabber
http://jackthegrabber.de/

u-Grabber v.0274exe EPG's lassen sich nicht laden
http://jackthegrabber.de/viewtopic.php?f=45&t=12707
Seite 2 von 2

Autor:  saggi [ So 26 Feb 2017, 10:37 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo Frank,

vielen Dank für den Test. So war es etwas leichter, den Fehler zu finden. Das schreiben der leeren Einträge sollte nun funktionieren.
Ich habe nochmals eine Version fertig gemacht. Wieder als komplettes Paket. Hier sollte der Fehler nicht mehr auftreten.

saggi

Edit: Anhang entfernt -> Download

Autor:  Pedant [ So 26 Feb 2017, 14:50 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo saggi,

das sieht gut aus.

0260 mit passender u-Grabber-Boxen.xml (ohne web-Zeilen) gestartet und EPG funktioniert.
0276 drüber kopiert und gestartet, EPG funktioniert jetzt auch
0276 beendet => leere web-Zeilen werden erzeugt.
Trägt man in die Felder Werte ein so werden diese korrekt gespeichert.

Das Problem betrachte ich daher als erledigt.

Bei mir bleibt nur diese Frage offen:
Warum werden die fehlenden web-Zeilen nicht erzeugt, wenn man Datei -> Einstellungen jetzt speichern ausführt?
Ebenso werden dabei auch frisch eingetragene oder geänderte Werte nicht in die XML geschieben.
Das Ändern der XML passiert erst wenn u-Grabber beendet wird.
Bezieht sich Datei -> Einstellungen jetzt speichern nur auf Einstellungen, die in der u-Grabber-Optionen.ini gespeichert werden oder wozu ist die Funktion gedacht?

Gruß Frank

Autor:  saggi [ So 26 Feb 2017, 16:51 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Pedant hat geschrieben:
Hallo saggi,

das sieht gut aus.

Sehr gut :wink:

Pedant hat geschrieben:
Bei mir bleibt nur diese Frage offen:
.....
Bezieht sich Datei -> Einstellungen jetzt speichern nur auf Einstellungen, die in der u-Grabber-Optionen.ini gespeichert werden oder wozu ist die Funktion gedacht?

Ich musste erst nachschauen: ja, es werden dann nur die Einstellungen in der ini gespeichert. Die .xml Dateien werden erst beim Beenden des Programms gespeichert.

saggi

Autor:  Pedant [ Mo 27 Feb 2017, 10:48 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo saggi,

gut, dann ist das geklärt.

Vielen Dank für das u-Grabber-Update.
Wenn jetzt noch gerti Erfolg meldet, wäre dieser Thread erfolgreich abgeschlossen.

Gruß Frank

Autor:  gerti [ Mo 27 Feb 2017, 17:26 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo saggi,

anbei die Log's nach den Einstellungen die du gesendet hast
einmal unter win7 64bit pro und einmal unter win7 32bit home

LG. gerti

Dateianhänge:
win 64bit pro u-Grabber-20170227_051323.log [4.86 KiB]
16-mal heruntergeladen
win 32 bit Home u-Grabber-20170227_050854.log [4.86 KiB]
14-mal heruntergeladen

Autor:  gerti [ Mo 27 Feb 2017, 17:57 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo Frank,

was heißt per Notepack diese Zeilen:
<web_user>Fred</web_user>
<web_password>Feuerstein</web_password>
ändern in:
<web_user></web_user>
<web_password></web_password>

LG. gerti

Autor:  Pedant [ Mo 27 Feb 2017, 18:53 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo gerti,

Zitat:
was heißt per Notepack diese Zeilen...

Das war nur dazu da, saggi zu beschreiben was ich ausprobiert habe und was es bewirkt hat.

Die Lösung des Problems ist u-Grabber auf die Version 0.2.7.6 upzudaten und schon ist alles gut.

Um dennoch zu erklären, was ich damit gemeint hatte:
Wenn Du im u-Grabber (Version 0.2.7.4 oder höher) in das Feld "Web Benutzer" Fred einträgst und ins Feld "Web Passwort" Feuerstein einträgst und dann den u-Grabber beendest, dann schreibt u-Grabber diese Werte in die XML und zwar in diese Zeilen:
<web_user>Fred</web_user>
<web_password>Feuerstein</web_password>

Wenn Du dann im Notepad diese XML-Datei öffnest, kannst Du die Zeichenfolge "Fred" und "Feuerstein" per Hand löschen, dass es anschließend so aussieht:
<web_user></web_user>
<web_password></web_password>
Wenn man dann u-Grabber wieder startet, sind die notwendigen Zeilen vorhanden und der EPG-Fehler tritt nicht auf.

So war das gemeint, aber machen muss das Keiner.
0.2.7.6 ist die Lösung, nicht Notepad.

Deine Logs zeigen, dass Du immernoch 0.2.7.4 benutzt und daher das Problem weiterhin besteht.

Gruß Frank

Autor:  gerti [ Di 28 Feb 2017, 10:53 ]
Betreff des Beitrags:  Re: u-Grabber v.0274exe EPG's lassen sich nicht laden

Hallo Frank,

jetzt funktioniert alles, super Danke!!!

LG. gerti

Seite 2 von 2 Alle Zeiten sind UTC + 1 Stunde
Powered by phpBB® Forum Software © phpBB Group
http://www.phpbb.com/