Portal  •  Foren-Übersicht  •  Dokumentation  •  Suche  •  Mitglieder  •  Impressum
Aktuelle Zeit: So 21 Jan 2018, 21:46

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 11 Beiträge ] 
Autor Nachricht
BeitragVerfasst: Do 14 Aug 2014, 10:40 
Offline
Gelegenheits-Streamer
Gelegenheits-Streamer
Benutzeravatar

Registriert: Mi 19 Apr 2006, 19:58
Beiträge: 45
Ich habe wieder eine Fehlermeldung beim Start von u-Grabber 0.2.7.4.
Wie das manchmal so ist, wurden vorher gleich mehrere Dinge geändert. A) neuste Win 7 updates, B) aktuellstes JtG-Image Snapshot 2.4.6 vom 16.3.2014
Die letzte (erfolgreiche) Aufnahme liegt schon etwas zurück. Heute wollte ich es wieder mal versuchen: folgende Fehlermeldung kommt beim Start und die Box wird nicht gefunden

Code:
14.08.2014 11:06:15: Start Version: 0.2.7.4
14.08.2014 11:06:15: Betriebssystem: Microsoft Windows 7 Ultimate  - 6.1.7601.65536
14.08.2014 11:06:15: Info: udrec.exe im Verzeichnis gefunden
14.08.2014 11:06:15: Info: udrec 0.13rc11 by Harald Maiss (www.haraldmaiss.de)
14.08.2014 11:06:15: Info: wget und abhängige DLL im Programmverzeichnis gefunden
14.08.2014 11:06:15: Info: Timer-XML im Einstellungsverzeichnis gefunden
14.08.2014 11:06:15: Info: MovieGuide-XML nicht im Einstellungsverzeichnis gefunden
14.08.2014 11:06:15: Info: Aufnahmen-XML im Einstellungsverzeichnis gefunden
14.08.2014 11:06:15: Timer aus Timer-XML geladen
14.08.2014 11:06:15: StartUp Zeiten geladen
14.08.2014 11:06:15: Programm-Tabelle geladen
14.08.2014 11:06:16: Aufnahmen-Datenbank geladen
14.08.2014 11:06:19: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 11:06:19: URL: http://192.168.1.10/
14.08.2014 11:06:20: Timer: Timerhandling aktiviert

Soll ich wieder ein altes Image flashen? Liegt es vielleicht an VB?
Ältere u-Grabber Versionen geben die gleiche Fehlermeldung. Bin auch testweise zurück auf Image Release 2.4.6 vom 10.10.2013, keine Änderung.
Bin für jeden hilfreichen Ratschlag dankbar.

Gruß
Thomas


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 12:21 
Offline
admin-c
admin-c
Benutzeravatar

Registriert: Mo 04 Aug 2003, 16:22
Beiträge: 4261
Wohnort: Bad Vilbel
Hallo Thomas,

zu dem Fehler fällt mir nicht konkretes ein, daher ein paar allgemeine Fragen:

Ist das yWeb-Interface der box erreichbar?
http://192.168.1.10

Ist in u-Grabber bei Optionen -> Box -> IP-Adressen
die Box korrekt eingetragen, inklusive Benutzername und Kennwort?

Kannst Du Dich mit dem PC bei der Box per telnet anmelden?
Eingabeaufforderung: telnet 192.168.1.10
Der Telnet-Client muss dazu im PC in der Systemsteuerung -> Programme -> Windows-Funktionen aktiviert sein.

Tritt der Fehler auch auf wenn Du die Windows-Firewall deaktivierst?

Gruß Frank

_________________
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 13:11 
Offline
Gelegenheits-Streamer
Gelegenheits-Streamer
Benutzeravatar

Registriert: Mi 19 Apr 2006, 19:58
Beiträge: 45
Pedant hat geschrieben:
Ist das yWeb-Interface der box erreichbar?
http://192.168.1.10

Ja

Zitat:
Ist in u-Grabber bei Optionen -> Box -> IP-Adressen
die Box korrekt eingetragen, inklusive Benutzername und Kennwort?

Ja, für telnet - Nein für web.

Zitat:
Kannst Du Dich mit dem PC bei der Box per telnet anmelden?
Eingabeaufforderung: telnet 192.168.1.10
Der Telnet-Client muss dazu im PC in der Systemsteuerung -> Programme -> Windows-Funktionen aktiviert sein.

Ja

Zitat:
Tritt der Fehler auch auf wenn Du die Windows-Firewall deaktivierst?

Davon abgesehen das u-Grabber und udrec sowieso unter den im Heimnetz zugelassenen Programmen gelistet sind - ja.

Dank und Gruß
Thomas


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 14:40 
Offline
admin-c
admin-c
Benutzeravatar

Registriert: Mo 04 Aug 2003, 16:22
Beiträge: 4261
Wohnort: Bad Vilbel
Hallo Thomas,

Zitat:
Ja, für telnet - Nein für web

Für Web hast Du aber keinen Kennwortschutz in der box aktiviert oder doch?
Ich glaube u-Grabber hat keine Möglichkeit auf ein kennwortgeschütztes y-Web zuzugreifen.

Gruß Frank

_________________
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 15:03 
Offline
Gelegenheits-Streamer
Gelegenheits-Streamer
Benutzeravatar

Registriert: Mi 19 Apr 2006, 19:58
Beiträge: 45
Nein, ist nicht aktiviert soweit ich das sehe. Ist auch nie verstellt worden.
Dateianhang:
Dateikommentar: Einstellungen WebServer
webserver.jpg
webserver.jpg [ 83.42 KiB | 5079-mal betrachtet ]


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 17:28 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo Thomas,

bitte versuche einmal einen Web-Benutzer und ein Passwort einzugeben. Anschließend beide Felder wieder leer machen und probieren ob es dann geht.

Wäre allerdings ungewöhnlich, das dann ältere Versionen das gleiche Problem haben.

saggi

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 17:36 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo Frank,

Pedant hat geschrieben:
Ich glaube u-Grabber hat keine Möglichkeit auf ein kennwortgeschütztes y-Web zuzugreifen.


in Version 0.2.7.4 schon ;)

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 20:02 
Offline
Gelegenheits-Streamer
Gelegenheits-Streamer
Benutzeravatar

Registriert: Mi 19 Apr 2006, 19:58
Beiträge: 45
Ich habe jetzt mal einen Test an Frauchens Rechner gemacht (auch Win 7 64 bit, aktuell). Dort lief es auch nicht. In einer virtuellen XP-Maschine auf meinem Win 7 Rechner lief es jedoch. Stets die selben kopierten Settings!
Dann habe ich nochmal an meinem u-Grabber gefummelt, und zwar "Aktuelle Box" hin und her bzw. aus und wieder an. Jetzt kommt folgende Meldung

Code:
14.08.2014 20:39:37: Start Version: 0.2.7.4
14.08.2014 20:39:37: Betriebssystem: Microsoft Windows 7 Ultimate  - 6.1.7601.65536
14.08.2014 20:39:37: Info: udrec.exe im Verzeichnis gefunden
14.08.2014 20:39:37: Info: udrec 0.13rc11 by Harald Maiss (www.haraldmaiss.de)
14.08.2014 20:39:37: Info: wget und abhängige DLL im Programmverzeichnis gefunden
14.08.2014 20:39:37: Info: Timer-XML im Einstellungsverzeichnis gefunden
14.08.2014 20:39:37: Info: MovieGuide-XML nicht im Einstellungsverzeichnis gefunden
14.08.2014 20:39:37: Info: Aufnahmen-XML im Einstellungsverzeichnis gefunden
14.08.2014 20:39:37: Timer aus Timer-XML geladen
14.08.2014 20:39:37: StartUp Zeiten geladen
14.08.2014 20:39:37: Programm-Tabelle geladen
14.08.2014 20:39:37: Lade u-Grabber-192.168.1.10-Channel2ID.xml
14.08.2014 20:39:37: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:37: URL: http://192.168.1.10/
14.08.2014 20:39:37: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:37: URL: http://192.168.1.10/
14.08.2014 20:39:37: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:37: URL: http://192.168.1.10/
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: GetMode: unknown
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:38: URL: http://192.168.1.10/
14.08.2014 20:39:38: LoadEPG: Das laden der Senderliste von 192.168.1.10 ist gescheitert!
14.08.2014 20:39:38: Aufnahmen-Datenbank geladen
14.08.2014 20:39:40: Timer: Timerhandling aktiviert
14.08.2014 20:39:40: Fehler bei Zugriff auf: 192.168.1.10, Meldung: Ungültige Konvertierung von Typ DBNull in Typ String.
   bei Microsoft.VisualBasic.CompilerServices.Conversions.ToString(Object Value)
   bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
14.08.2014 20:39:40: URL: http://192.168.1.10/


Dann habe ich mal "u-Grabber-192.168.1.10-Channel2ID.xml" gelöscht und u-Grabber neu gestartet - wieder kein Erfolg.
Bemüht Euch nicht weiter, ich meine es liegt irgendwo am OS. Vielleicht lösche ich morgen mal die Settings und gebe alles nochmal händisch ein.

Gruß
Thomas


Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Aug 2014, 20:14 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo Thomas,

kannst du bitte folgende Datei "u-Grabber-Boxen.xml" mal löschen/umbenennen?

saggi

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
BeitragVerfasst: Fr 15 Aug 2014, 8:28 
Offline
Gelegenheits-Streamer
Gelegenheits-Streamer
Benutzeravatar

Registriert: Mi 19 Apr 2006, 19:58
Beiträge: 45
Nun sitze ich froh aber etwas ratlos da. Die "Kur" hat geholfen.

Ich habe die u-Grabber-Boxen.xml umbenannt und die Daten zur Box nochmal eingegeben, der Vollständigkeit halber mit Web-Name/-Passwort.
Nach einem Neustart war erst keine Box auswählbar. Zurück in die Optionen und die Zeile markiert, jetzt ging eine Auswahl.

Wieder Neustart. Jetzt war die Senderliste sofort da. Jippi... Es kann doch nicht das Web-Passwort sein, oder? Hatte ich doch schon versucht?!

Mit einem Editor habe ich also die u-Grabber-Boxen.xml geöffnet und habe spaßeshalber die Zeilen <web_user>root</web_user> und <web_password>dbox2</web_password> entfernt. Nach einem Neustart ging es wieder nicht. Ha, erwischt. Der andere Unterschied zur alten xml, <GUI>unknown</GUI> statt <GUI>Neutrino</GUI> war es sicherlich nicht.

Die vorher gelöschten Zeilen per Ctrl+Z und Speichern wieder eingefügt und neu gestartet, alles wieder gut. Freu...

Etwas ratloses Kopfschütteln über die ganzen Zusammenhänge bleibt dennoch. So habe ich das mit dem Web-Name/-Passwort doch vorher schon probiert gehabt und warum läuft es auf XP auch ohne?

Die gleiche "Kur" habe ich jetzt mal mit u-Grabber 0.2.6.12 gemacht, der ja noch kein Web-Name/-Passwort hatte und auch keinen Kontakt zur Box herstellen konnte. Anschließend lief auch diese Version wieder.

Naja, etwas lang geworden, die Kollegen gucken schon so komisch. Vielen Dank jedenfalls für den Beistand. Wie man immer so sagt: kaum macht man es richtig, funktioniert es.

Gruß
Thomas


Nach oben
 Profil  
 
BeitragVerfasst: Fr 15 Aug 2014, 9:53 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo Thomas,

ich drücke mich mal so aus: Dich trifft keine Schuld daran. Die Funktion sich mit Name und Passwort anzumelden ist neu. Ich habe das hier mehr oder weniger gut probiert, aber ob die xml einer alten Version (oder eben wenn die Zeilen gelöscht werden) angepasst und kontrolliert werden habe ich wohl nicht geprüft. Ich schaue mir das nochmal genauer an.

Vielen Dank für Deine Rückmeldung.

saggi

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 11 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de