Portal  •  Foren-Übersicht  •  Dokumentation  •  Suche  •  Mitglieder  •  Impressum
Aktuelle Zeit: Di 23 Jan 2018, 13:10

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 14 Beiträge ] 
Autor Nachricht
BeitragVerfasst: Sa 05 Jan 2013, 14:24 
Hallo,

ich hoffe auf Hilfe zur Fehlersuche bei o.g. Problem.

System: Win XP SP 3
Netframe 1.1 3.5 und 4
D-Box mit JtG-Image von September 2012 ohne Snapshots
Benutzerkennwörter vergeben
NSendKey F5 in U-Grabber integriert
U-Grabber (nicht als Setup) Udrec 0.13rc11 im Programmvereichnis

Folgendes Szenario spielt sich ab: Timer wird programmiert und Notebook in Standby schlafen geschickt. Notebook wacht wieder auf schaltet ggf. auf programmierten Kanal um. Kurz nach Aufnahmestart bricht die Aufname ab und Notebook geht schlafen, die D-Box befindet sich weiter im Record-Mode. Was mich wundert:

Zitat:
Fehler bei Zugriff auf: 192.168.0.202, Meldung: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden.
bei System.Net.HttpWebRequest.GetResponse()
bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)


Fehlt irgendwas im Programmverzeichnis von U-Grabber oder ist eine Einstellung im Image fehlerhaft?
Log im Anhang. Dazu ist zu sagen das ich händisch das Notebook um 6:40Uhr geweckt habe.

Ansonsten läuft U-Grabber normal, Sofortaufnahmen sind möglich, wenn ein Timer programmiert ist und das Notebook anbleibt waren die Aufnahmen okay.

Ich habe mal zu Testzwecken JTG mit dem DBox Shedule Tool installiert, hier lief alles problemlos durch.

Unterschied zu U-Grabber: Die von JtG erstellen .ts Streams kann ich im VLC-Player nicht anschauen, die von U-Grabber schon. Gibt es eine Erklärung dafür ?

Vielen Dank im Voraus für die Hilfe.


Edit: Habe in einem anderen Thread gelesen, das es am Timeout-Wert von 2000 liegen könnte. Werde den Wert erhöhen und testen, melde mich dann.


Dateianhänge:
Dateikommentar: Log von der fehlgeschlagenen Aufnahme.
u-Grabber-20130105_064207.log [9.42 KiB]
20-mal heruntergeladen
Nach oben
  
 
BeitragVerfasst: Sa 05 Jan 2013, 16:56 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo eggipdm,

es sieht so aus, als ob u-Grabber nicht erkennt, das der Energiemodus sich geändert hat. Und als er die Änderung erkennt wird auch kein Programm aufgerufen(laut Log).
Code:
05.01.2013 06:40:30: Energie: u-Grabber aus Ruhezustand zurück
05.01.2013 06:40:30: GetEPG: ok
05.01.2013 06:40:49: |192.168.0.202|06:40:49 1295873 packets lost
05.01.2013 06:40:49: |192.168.0.202|06:40:49 -1536 packets lost
05.01.2013 06:40:49: |192.168.0.202|06:40:49 2 packets lost
05.01.2013 06:41:35: Timeraufnahme: The Italian Job - Jagd auf Millionen wird abgebrochen!

Ich würde NSenkeyF5 über die ini während der Aufname aufrufen lassen. Bei Dir wohl mit einem Abstand von 2 min.
Die ini erreicht man am schnellsten durch einen Klick auf "Einstellungsverzeichnis" im Menü "Hilfe".
Dort folgenden Eintrag erstellen:
Code:
[Extra]
Programm=D:\temp\NSendKeyF5.exe
Minuten=2

Den Pfad natürlich anpassen.

Ich hoffe, das es hilft.

saggi

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
BeitragVerfasst: So 06 Jan 2013, 22:34 
Hallo Saggi,

vielen Dank für deinen schnellen Tipp.

Folgendes habe ich verändert:
- Energieotionen des Notebooks von "Tragbarer Laptop" auf "Desktop" umgestellt -> Unterschied:
jetzt erscheint auf dem Display das Bild, bei "Tragbarer Laptop" blieb das Display nach dem
Aufwachen schwarz, erst durch Betätigen der "Pfeil-Unten-Taste" wurde das Display hell
- NSendKey F5 als Programm eingebunden, hat eine Weile gedauert erst nach Eigabe
eines Argumentes (%recdir%) bieb das Programm gespeichert. Gibt es ein Argument was
standardmäßig verwendet wird, konnte in der Doku nichts finden.
- Timeout für Anfragen auf 15sec. eingestellt

Eine Testaufnahme war erfolgreich. Log hab ich angehängt. Da ich nicht der große Experte bin würde ich dich bitten mal drüber zu schauen ob es noch Auffälligkeiten gibt.

Heute nacht werde ich eine Aufnahme vom ZDF programmieren und gebe dann bescheid ob alles
glatt gelaufen ist.

Vielen Dank nochmals.


Dateianhänge:
u-Grabber-20130106_095735.log [10.36 KiB]
11-mal heruntergeladen
Nach oben
  
 
BeitragVerfasst: Di 08 Jan 2013, 11:55 
Hallo saggi,

Und es klappte doch nicht. Zwei Versuche eine ZDF-Sendung aufzunehmen sind fehlgeschlagen. Und ich habe kein Idee warum.

Was ich noch verändert habe:
Energieoptionen wieder zurückgestellt, im Netzbetrieb bleibt bis auf das Display alles an.

NSendKey jetzt über die .ini eingebunden

Eine Testaufname vom WDR lief durch, wie gesagt ZDF nicht. Was mir aufgefallen ist:

Zitat:
07.01.2013 20:13:04: |192.168.0.202|-----udrec-Info-----
07.01.2013 20:13:19: |192.168.0.202|20:13:19 to DBox: VIDEOTS 31341 16 0 1 vaaaaaa 06e 078 079 07a 07d 064 000
07.01.2013 20:13:19: |192.168.0.202|20:13:19 from DBox: ERROR: main() - illegal arguments
07.01.2013 20:13:19: |192.168.0.202|20:13:19 from DBox: EXIT
07.01.2013 20:13:19: |192.168.0.202|Aufnahme(udrec) wurde unerwartet abgebrochen.
07.01.2013 20:13:19: |192.168.0.202|-----udrec-Ende-----
07.01.2013 20:13:19: Aufnahme beendet.
07.01.2013 20:13:19: |192.168.0.202|----Aufnahmeinfo----
07.01.2013 20:13:19: |192.168.0.202|Videogrösse: Datei wurde nicht erstellt
07.01.2013 20:13:19: |192.168.0.202|Videodatei:
07.01.2013 20:13:19: |192.168.0.202|Endzeit: 07.01.2013 20:13:19
07.01.2013 20:13:19: |192.168.0.202|--------------------


Im Anhang beide vollständigen Logs. Vielleicht siehts du was und kannst mich unterstützen.

VG von eggipdm


Dateianhänge:
u-Grabber-20130108_064513.log [14.35 KiB]
16-mal heruntergeladen
u-Grabber-20130107_071707.log [8.77 KiB]
19-mal heruntergeladen
Nach oben
  
 
BeitragVerfasst: Di 08 Jan 2013, 19:04 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo,
sorry, gestern habe ich es nicht geschafft.

Das Problem bei den ZDF-Aufnahmen scheint an der Anzahl der Audiospuren bei Aufnahmen von der DBox.
Ich hatte bereits an einer Lösung gearbeitet und stelle sie hier zur Verfügung. Am Wochenende dann wieder an gewohnter Stelle im Downloadbereich.
Folgendes hat sich geändert.

GUI:
Dateianhang:
2013-01-05_110009.png
2013-01-05_110009.png [ 247.78 KiB | 9660-mal betrachtet ]


Und das wichtige für Dich:
Dateianhang:
2013-01-05_111210.png
2013-01-05_111210.png [ 102.77 KiB | 9660-mal betrachtet ]

Hier bitte für die Box die ZDF Kanäle die Audios deaktivieren, die nicht benötigt werden, ich würde APid 2 deaktivieren.
Diese Einstellung überschreibt alle Voreinstellungen der Tonspuren, bei Direktaufnahmen ebenso wie beim Streamingserver.

Ich hoffe, das hilft.

saggi

Edit: Anhang entfernt

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
BeitragVerfasst: Mi 09 Jan 2013, 9:02 
Hallo saggi,

und weiter geht es :wink: .

Mutig wie ich bin habe ich gleich zwei Aufnahmen programmiert, einmal ARD und einmal ZDF.
Wobei zum Start des ARD-Stream der PC wach war. Lt.Log ist der PC nach der ersten Aufnahme eingeschlafen und zur zweiten Aufnahme wieder aufgewacht und hat begonnen aufzunehmen. NsendKey hat ebenfalls gearbeitet.
Und dann einfach ausgegangen. :( Im Log ist scheinbar der Abbruch nicht aufgezeichnet.

Zitat:
09.01.2013 01:28:08: Starte C:\Dokumente und Einstellungen\Eric\Eigene Dateien\Downloads Software\U-Grabber\NSendKeyF5.exe, Aufnahme läuft
09.01.2013 01:30:08: Starte C:\Dokumente und Einstellungen\Eric\Eigene Dateien\Downloads Software\U-Grabber\NSendKeyF5.exe, Aufnahme läuft
09.01.2013 06:51:28: Fehler bei Zugriff auf: 192.168.0.202, Meldung: Die Verbindung mit dem Remoteserver kann nicht hergestellt werden.
bei System.Net.HttpWebRequest.GetResponse()
bei u_Grabber.clsHTTPD.InetReadFile(String sURL, Int32 tOut, Boolean UseProxy, Boolean ReturnUTF8)
09.01.2013 06:51:28: URL: http://192.168.0.202/control/epg?eventi ... 6001173039
09.01.2013 06:51:28: GetEPG: EPG für EventID 303711506001173039 nicht vorhanden
09.01.2013 06:51:44: |192.168.0.202|06:51:38 7249918 packets lost
09.01.2013 06:51:44: Energie: u-Grabber aus Ruhezustand zurück


06:51 Uhr manueller Start des PC durch mich.

Was könnte ich noch probieren ? Beispielsweise eine andere sprich ältere Udrec benutzen oder anderes Image für die Box flashen ?

Log wie immer wieder dran.

Vg von eggipdm


Dateianhänge:
u-Grabber-20130109_065331.log [27.21 KiB]
13-mal heruntergeladen
Nach oben
  
 
BeitragVerfasst: Sa 12 Jan 2013, 23:03 
Hallo saggi,

zur Info. Ich habe weiterhin getestet. Eine einzige Timeraufnahme hat funktioniert, mehrere sind fehlgeschlagen. Der PC schläft einfach kurz nach Start der Aufnahme ein ohne ein Loginfo zu hinterlassen, soweit ich das überblicken kann. Und es ist kein ZDF- spezifisches Problem. Wenn du die Logs braucht sende ich sie dir.

Derweil bin ich erstmal auf JtG umgestiegen. Hier läuft alles rund.

Wenn du möchtest spiele ich weiter auch Versuchskaninchen.

Schönes WE wünscht eggipdm.


Nach oben
  
 
BeitragVerfasst: Mi 16 Jan 2013, 12:47 
Offline
admin-c
admin-c
Benutzeravatar

Registriert: Mo 04 Aug 2003, 16:22
Beiträge: 4261
Wohnort: Bad Vilbel
Hallo eggipdm,
Zitat:
Energieotionen des Notebooks von "Tragbarer Laptop" auf "Desktop" umgestellt...

Wie sehen denn die Energieoptionen des Systems im Details aus, genauer gefragt, ist bei Standby "Nie" oder eine Zeitspanne selektiert?
Da NSendKeyF5.exe so eingebunden ist, dass es alle 2 Minuten ausgeführt wird, sollte die Einstellung allerdings egal sein, falls Sie nicht auch auf 2 Minuten oder kürzer steht.

Zitat:
Was könnte ich noch probieren ? Beispielsweise eine andere sprich ältere Udrec benutzen oder anderes Image für die Box flashen?

Ein älteres udrec würde ich nicht nehmen und als Image empfehlen wir natürlich das JtG-Team-Image.
Du könntest aber auch mal ein anderes supportfähiges Image ausprobieren.

Wenn die erste Aufnahme funktioniert und der Rechner bei der Zweiten einschläft, könnte es auch an der Box liegen. Es könnte also so ablaufen, dass die Box mehr oder weniger abstürzt und dann keine Daten mehr an u-Grabber liefert. Für u-Grabber könnte damit die Aufnahme beendet sein und somit wird dann vielleicht auch NSendKeyF5.exe nicht mehr aufgerufen, die Folge: Der Rechner schläft wieder ein, weil er eventuell laut Systemeinstellungen nach einer Zeit der Inaktivität genau das tun soll.
Ob das beschriebene Szenario mit den vorhandenen Logs und dem Standardverhalten von u-Grabber vereinbar ist, kann ich allerdings nicht beurteilen.
Mir stellt sich aber die Frage, ob die Box nach der Zweiten, der gescheiterten, Aufnahme noch in einem stabilen Zustand ist, der beispielsweise eine manuelle Sofortaufnahme zulässt oder eben nicht.

Wie laufen denn zwei Timeraufnahmen ab, wenn Du den Rechner testweise mal an lässt und ihn nicht dazwischen und danach automatisch einschlafen lässt?

Gruß Frank

_________________
Sagem 1xi + HDD Kabel, JtG-Team Image v2.4.6 (19.12.2015), avia600vb028, ucode int., cam_01_02_105D
Coolstream Neo, FW 2.10
Win 10 Pro x64, E8400 3.0/1033, 4GB, WNDR3700v2 DD-WRT v24-sp2 (06/14/11) std
u-Grabber 0.2.7.6-> TS -> PX 0.91.0.08 -> IfoEdit 0.971 -> ImgBurn 2.5.0.0 -> DVD-R


Nach oben
 Profil  
 
BeitragVerfasst: Sa 19 Jan 2013, 21:14 
Hallo Pedant,

Energieoptionen sind folgende:

Display aus : 15min
FP ausschalten: nie
Standby: nie

Auf der Box ist seit einigen Tagen das JtG-Image 2.4.5 frisch eingespielt.

Heute probiere ich zunächst eine Aufnahme ohne das der Laptop aus dem Schlaf erwacht, sprich er ist an. Alles weitere teste ich auch und melde mich in den nächsten Tagen wieder.


Nach oben
  
 
BeitragVerfasst: Fr 01 Feb 2013, 18:25 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Pedant hat geschrieben:
Ob das beschriebene Szenario mit den vorhandenen Logs und dem Standardverhalten von u-Grabber vereinbar ist, kann ich allerdings nicht beurteilen.

Hallo Frank,

ist es nicht. Das System schaltet den Rechner aus, u-Grabber hat damit nichts zu tun.

Hallo eggipdm,

ich kenne das von Dir beobachtete Verhalten unter WXP nicht. Dort hat es spätestens mit NSendkeyF5 immer funktioniert. Ich suche derzeit nach einer Möglichkeit den Standby aus dem Programm selbst zu verhindern. Ich kann das aber leider immer nicht nachstellen und testen...

saggi

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
BeitragVerfasst: Mo 18 Feb 2013, 20:08 
Hallo zusammen,

so richtig bin ich nicht vorwärts gekommen. Zunächst sah es so aus ob alles funktioniert (erste beiden Logs). Einmal mit Aufwachen des Laptops mit zwei Aufnahmen. Bei zweiten mit Laptop in Betrieb. Die dritte schlug wieder fehl. Man könnte denken das der Laptop manchmal nicht richtig wach wird und er geht gleich wieder schlafen (wie Menschen auch halt). Und komischweise arbeitete NsendKey auch nicht. Habe ich auch nochmal nachgeschaut, korrekt sollte sie eingebunden sein.

Die Nachtaufnahmen werde ich im Moment mit JtG realisieren, stehe aber weiterhin zu testzwecken zur Verfügung :wink:


Dateianhänge:
Dateikommentar: Abbruch
u-Grabber-20130206_094520.log [10.45 KiB]
14-mal heruntergeladen
Dateikommentar: Aufnahme ohne Standby
u-Grabber-20130122_063248.log [8.82 KiB]
13-mal heruntergeladen
Dateikommentar: Aufanhmen mit Standby
u-Grabber-20130121_061123.log [17.1 KiB]
15-mal heruntergeladen
Nach oben
  
 
BeitragVerfasst: Mo 11 Mär 2013, 19:13 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
Hallo eggipdm,

sorry für die lange Wartezeit. Ich habe mal die Windows API eingebunden um dem System Anforderungen der Nutzung während der Aufnahme zu senden. Kannst Du die Version noch einmal testen?

Danke.

saggi


Dateianhänge:
Dateikommentar: u-Grabber Debug 0.2.7.4
u-Grabber-0274.zip [755.1 KiB]
30-mal heruntergeladen

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)
Nach oben
 Profil  
 
BeitragVerfasst: Do 14 Mär 2013, 17:54 
Hi Saggi,

wird gemacht. NSendKey mit einbinden ?

Gruß eggipdm


Nach oben
  
 
BeitragVerfasst: Do 14 Mär 2013, 19:05 
Offline
u-Grabber Dev
u-Grabber Dev
Benutzeravatar

Registriert: So 21 Mär 2004, 15:11
Beiträge: 1173
eggipdm hat geschrieben:
Hi Saggi,

wird gemacht. NSendKey mit einbinden ?

Hallo eggipdm,

sollte nicht nötig sein.

Danke

_________________

MovieGuider aktuelle Version: 0.3.10.6 Anleitung| FilmDB aktuelle Version: 0.1.1.7|u-Grabber aktuelle Version 0.2.7.6

Das Wort heißt Standard ;)


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 14 Beiträge ] 

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de